Cluster management user not found error

Hi, I am new to gravity and just tried installing a single-node cluster on an Ubuntu VM.

I used the quickstart instructions here:

At the end of the installation, I get an output as follows:

Wed Oct  9 20:54:11 UTC Installation succeeded in 28m7.992989036s
Wed Oct  9 20:54:11 UTC
Cluster endpoints:
    * Authentication gateway:
    * Cluster management URL:

Application endpoints:
    * mattermost:2.2.0:
        - Mattermost:

The cluster is up and running. Please take a look at "cluster management" section:

So, I try creating a user as follows:

root@grex:~/quickstart# ./gravity users add --roles=@teleadmin jordan
Signup token has been created and is valid for 8h0m0s hours. Share this URL with the user:
NOTE: make sure this URL is accessible!

When going to the signup url, entering a password and clicking “CREATE ACCOUNT”, I get a red box on top of the sign up form that says

user(name="3e70ec81-df5e-4523-99a4-cbdca7c2b84f.quirkykeller8605") not found

I tried resetting the password using ./gravity users reset jordan but the same error gets reported in the same way.

Another strange thing that may be related here is that I tried first installing using the non-technical ./install script, and all I got was a url expecting username, password, and Google Authenticator token – with no way to proceed.

Note that the deployment of Mattermost is working perfectly, all pods in all namespaces are either Running or Completed, and ./gravity status returns the following:

Cluster status: active
Application:    mattermost, version 2.2.0
Join token:     890iop
Last completed operation:
    * operation_install (3d7a0d3f-f12e-48a1-bb53-e594a4a762f3)
      started:          Wed Oct  9 20:26 UTC (3 hours ago)
      completed:        Wed Oct  9 20:26 UTC (3 hours ago)
Cluster endpoints:
    * Authentication gateway:
    * Cluster management URL:
Cluster nodes:  quirkykeller8605
        * grex / / node
            Status:     healthy

Just following up on the post here based on conversation in Slack.

Github issue for this is being tracked here.

User is actually being created in this case, but the UI is giving a misleading error. Disregarding the error you should still be able to log in with the user created.

1 Like

Hi @jordan-uipath!

I have confirmed this as being a regression that affects recent 6.x releases.

Both issues you’re mentioning (“not found” upon user creation and login screen when trying to use UI-based installation) are the result of the same bug in one of the gravity’s dependencies which I’m now working on a fix for.

You can use the Github ticket Abdu linked above to track the status of the issue - I will close it with the numbers of patch releases containing the fix once they are published.

Sorry about the issue!


1 Like

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.