"NoCredentialProviders: no valid providers in chain."

Hello everyone! I’m at my wits end with this error message, but I’m trying to setup AWS S3 access for my Gravitational Teleport configuration [ 1 ] which you can see below and I keep getting this message about [ 2 ] when running the command journalctl -xe:

Nov 01 18:05:36 jump.gekkofyre.io teleport[19636]: error: "NoCredentialProviders: no valid providers in chain. Deprecated.\n\tFor verbose messaging see aws.Config.CredentialsChainVerboseErrors, initialization failed"

[ 1 ] - https://paste.gekkofyre.io/view/2b950d83
[ 2 ] - https://paste.gekkofyre.io/view/6c95ee7a

I’ve tried everything including modifying the AWS CLI settings in multiple ways [ 3, 4 ]

If anyone can help then that would be sincerely appreciated, thank you. I apologize for all the links too but I don’t know what this discussion board can support and I didn’t want to make a mess of this page :confused:

It wouldn’t let me paste these links in the original post, so here they are:

[ 3 ] - https://paste.gekkofyre.io/view/2446243d
[ 4 ] - https://paste.gekkofyre.io/view/b249ca72

If you’re running Teleport via systemd then it won’t have access to the ~/.aws/credentials file due to sandboxing.

There’s a few ways you can solve this - the quickest way (at least for testing) is probably to add the credentials to your systemd unit file.

Edit /etc/systemd/system/teleport.service and add these lines to the [Service] section (obviously with your correct credentials):


Then systemctl daemon-reload and systemctl restart teleport. Let us know how you get on.

1 Like

@gus Thank you so much! This immediately solved my issue regarding that particular problem and I apologize for the late reply, but I was still figuring out how to work Teleport at just a basic level. I’m kind of getting the hang of things now but yeah, still learning! Many thanks :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.