Tsh login issues

Hi team, we are looking to use teleport as jumphost for EKS cluster

a) teleport deployed in ec2 and kubernetes enabled
b) created eks cluster and copied kubeconfig in teleport server, my kubecofig user looks the following

d) created a teleport user in local and can login in teleport UI

e) when tried tsh login, got the error,

tsh --proxy=xxxx:3080 --insecure --auth=local --user=user1 login

error: unexpected EOF


Original Error: *errors.errorString unexpected EOF

Stack Trace:

/tmp/20190827T134557/src/github.com/gravitational/teleport/lib/client/api.go:387 github.com/gravitational/teleport/lib/client.readProfile

/tmp/20190827T134557/src/github.com/gravitational/teleport/lib/client/api.go:483 github.com/gravitational/teleport/lib/client.Status

/tmp/20190827T134557/src/github.com/gravitational/teleport/tool/tsh/tsh.go:382 main.onLogin

/tmp/20190827T134557/src/github.com/gravitational/teleport/tool/tsh/tsh.go:324 main.Run

/tmp/20190827T134557/src/github.com/gravitational/teleport/tool/tsh/tsh.go:174 main.main

/usr/local/go/src/runtime/proc.go:209 runtime.main

/usr/local/go/src/runtime/asm_amd64.s:1338 runtime.goexit

User Message:

Hi @thirukkumaran,

What does the User Message read off? It appears to be cut off.

Can you share what Teleport/tsh version you are on? (You can check by teleport version and tsh version)

Any other debug logs collected? Whenever teleport services do not start you can take a look at sudo journalctl -fu teleport.

Also have you tried running in debug mode by adding the -d flag.


https://aws.amazon.com/blogs/opensource/authenticating-eks-github-credentials-teleport/ is a great resource for setting up Teleport with EKS - I would reference this to make sure that you’ve configured everything that’s needed.

$ teleport version

Teleport v4.0.5 git:v4.0.5-0-gfd33a8a4 go1.12.1

$tsh version

Teleport v4.0.5 git:v4.0.5-0-gfd33a8a4 go1.12.1

b) given was the full error message with -d flag

c) don’t see errors in sudo journalctl -fu teleport .

not sure if this could be related to certs, working on adding valid certs,

thanks, let me try it,

1 Like

https://aws.amazon.com/blogs/opensource/authenticating-eks-github-credentials-teleport/ works fine, thanks a lot!

1 Like

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.